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Abstract

This document describes how to install Celoxis.
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1.1. Hardware (Minimum Requirements)

1. Processor: Minimum Intel P4 2.4 Ghz or equivalent.

2. Memory: Min 1 GB. 2 GB is recommended for better performance.

3. Disk space: 100MB for the software. Space requirements for your data will depend on the size of the data (number
of projects, tasks, status updates etc) and documents you upload. We recommend that you consider atleast 10GB.

1.2. Software

1. Operating System : Microsoft Windows (XP/2003/Vista/2008) or Linux

2. Java : Java SDK 1.6 from Sun Microsystems

3. Database : Microsoft SQL Server 2005/2008, Oracle 9i or PostgreSQL 8.1+. PostgreSQL is a free, open source
production quality database. Celoxis also works with Express editions of Microsoft SQL Server 2005 or 2008
which are free.

4. Email Server with SMTP and IMAP4 or POP3
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Table of Contents
2.1. PostgreSQL 8.x ......................................................................................................................................  2
2.2. Microsoft SQL Server 2005/2008 ............................................................................................................  3
2.3. Oracle 9i ................................................................................................................................................  4

Note

Celoxis provides a debugging tool to verify you have configured your database correctly. Visit http://
download.celoxis.com/jdbctest for more information

2.1. PostgreSQL 8.x

Note

The instructions are for example only, please talk to your database and system administrator to secure
your database server

1. First ensure that your PostgreSQL server is accepting TCP/IP connections from localhost and from the machines
on your internal network.

To enable TCP/IP connections :

1. Edit postgresql.conf (On linux, this will be most likely in /var/lib/pgsql/data while on Mi-

crosoft Windows, it is easily accessible from pgAdmin's File→Open postgresql.conf...)

2. Search for Connection Settings

3. Uncomment the line (if not already) listen_addresses = '*' i.e. it should not have # as the prefix.

4. Save the file and exit

To allow connections from your local network :

Assuming your network address is 192.168.0.0 and network mask is 255.255.255.0

1. Edit pg_hba.conf (On linux, this will be most likely in /var/lib/pgsql/data while on Microsoft

Windows, it is easily accessible from pgAdmin's File→Open pg_hba.conf...)

2. Add the following lines to that file. If Celoxis will be running on the same server as your Postgresql server,
then you only need the first line below.

  local  all  all  trust 
  host   all  all  127.0.0.1     255.255.255.255 trust
  host   all  all  192.168.0.0   255.255.255.0   trust

3. Save the file and exit

http://download.celoxis.com/jdbctest
http://download.celoxis.com/jdbctest
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Once you do the above changes, restart Postgresql. (On Linux, as root, type : /etc/init.d/postgresql

restart and on Microsoft Windows choose Stop service and then Start service from All Programs→Postgresql
8.x)

2. Create a database user with name celoxis with a password. Note this down, you will be asked for this during
installation.

On Linux, to create a user, use the createuser command as shown below :

$ createuser celoxis
Shall the new role be a superuser? (y/n) n
Shall the new role be allowed to create databases? (y/n) y
CREATE ROLE
$

On Microsoft Windows :

1. Open pgAdmin tool

2. Open the appropriate server node

3. Right click on Login Roles and choose New Login Role...

4. Enter celoxis as the Role name and optionally enter a password. Ensure that Account expires is empty.

5. Select the Can create database objects option from Role Privileges

6. Click OK

3. Create a database with UNICODE (or UTF8) character encoding where owner is the user celoxis. The database
name should be the same as specified in your license request.

On Linux, to create a database with name celoxis, use the createdb command as shown below :

$ createdb -E UNICODE -U celoxis celoxis
CREATE DATABASE
$

On Microsoft Windows:

1. Open pgAdmin tool

2. Open the appropriate server node

3. Right click on the Databases node and choose New Database...

4. Enter the correct database name, pick celoxis as the owner and choose UTF8 as the encoding

5. Click OK

2.2. Microsoft SQL Server 2005/2008

There are many different editions of the Microsoft SQL Server 2005 and 2008 database servers including their Express
editions which are free to use. The following are instructions for Microsoft SQL Server 2008 Express Edition. Settings
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for other editions will be similar. Please contact your database administrator in case you have any questions. But in
essense, we have to create a database and a database user who has all rights on that database.

To create a database user and database, open SQL Server Management Studio and login as sa (the database admin-
istrator user).

To create a database user :

1. Right click on the Security node and click New→Login...

2. Enter login name as celoxis

3. Choose SQL server authentication

4. Enter a password. Note the username and password down as you will be asked for this later during installation.

5. Uncheck the Enforce password policy

6. Click OK

To create a database :

1. Right click on the Database node and click New Database...

2. Enter the same database name as specified in your license request

3. Select celoxis as the owner

4. Choose SQL_Latin1_General_CP1_CI_AS as the Collation (available from the Options page on the left)

5. Click OK

2.3. Oracle 9i

If you are using Oracle please contact your database administrator to setup the database with the following criteria :

1. Create a database with UTF8 character encoding where owner is the user celoxis. The database name should
be the same as specified in your license request. Ensure that the Oracle SID and database name match.

2. Create a database user e.g. celoxis. Grant this user all permissions on the database. Also, give this user unlimited
quota for tablespace users.
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3.1. Before You Begin

1. Your database server must be up and running and you must have created a database and a database user for
Celoxis. If not, first do that as described in Database Setup (Chapter 2) [2]

2. Download and install JDK 6 from http://java.sun.com/javase/downloads/index.jsp

3. Set the JAVA_HOME environment variable to the path where JDK is installed. For example, on our Mi-
crosoft Windows computer it is set to C:\Program Files\Java\jdk1.6.0_14 while it is /usr/ja-
va/jdk1.6.0_14 for our Linux computer. In other words, the directory pointed to by JAVA_HOME should
contain the bin sub directory.

On Microsoft Windows :

1. Right click on My Computer

2. Click Properties

3. Click on the Advanced tab (or click on Advanced system settings in Windows Vista)

4. Click the Environment Variables... button

5. Under System variables, click New...

6. Set variable name to JAVA_HOME and variable value to the path to JDK

7. Click OK

8. Click OK on the Advanced tab to close the window

On Linux :

1. Open a terminal and login as the user that will start Celoxis

2. In the appropriate profile file (e.g. .bash_profile or .profile), type: export
JAVA_HOME=path-to-jdk

3. Save the file

4. Logout and Login again

4. Confirm your JAVA_HOME environment variable is correctly set

http://java.sun.com/javase/downloads/index.jsp
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On Microsoft Windows :

Open a command prompt and type %JAVA_HOME%\bin\java -version and you should see something
as shown below :

c:> "%JAVA_HOME%\bin\java" -version
java version "1.6.0_14"
Java(TM) SE Runtime Environment (build 1.6.0_14-b08)
Java HotSpot(TM) Client VM (build 14.0-b16, mixed mode, sharing)
c:> 

On Linux :

Open a command prompt and type $JAVA_HOME/bin/java -version and you should see something
as shown below :

$ $JAVA_HOME/bin/java -version
java version "1.6.0_14"
Java(TM) SE Runtime Environment (build 1.6.0_14-b08)
Java HotSpot(TM) Client VM (build 14.0-b16, mixed mode, sharing)
$ 

In case you see any errors, go back to the previous step and check whether you have set the environment variable

5. You should have received a license.properties file in email from us that contains your license infor-
mation. Save that file on to your computer. You will be asked to upload this file during the installation process.

6. Keep your database information ready: database name, login, password. You will be asked to input these during
the installation process.

3.2. Downloading and Starting the Celoxis Server

1. You must have received instructions from us on how to download the software. Download the file. The download
will be a file like psa_x.y.z.zip.

2. Create a folder where Celoxis will be installed: C:\celoxis on Microsoft Windows using Windows Explorer
and /usr/local/celoxis on Linux.

3. Place the zipped file in that folder and unzip it using your favorite unzip tool.

4. You should now have C:\celoxis\psa_x.y.z directory and this directory should have the bin sub direc-
tory. On Microsoft Windows browse to this folder. On Linux go to this folder using a terminal window.

5. On Microsoft Windows, double click on startup.bat. This will open a window. Do not close that window.
On Linux, run startup.sh from the command line.

6. Celoxis server is now running and ready for installation.

3.3. Starting the Installation Process

Open http://your-server-name:8888/psa/Install.do in a browser and follow the instructions. They
are self explanatory.
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3.4. Configuring Mail Server

Before you start using Celoxis, you need to configure Celoxis with the mail server information. Read mail server
setup for detailed information on how to do this.

3.5. Administrative Setup

Login as administrator and:

1. Complete the information about your company.

2. Setup holidays.

3. Setup working hours.

4. Add users.

3.6. Celoxis as a Windows Service

Important

Before you install Celoxis as a service, ensure that application has been installed successfully

To install Celoxis as a Service : 

1. Open a command prompt (if you are using Vista or Windows 2008 server, you will need to run the command
prompt using "run as administrator")

2. cd to <CELOXIS-INSTALL-DIR>/psa_x.y.z/bin directory

3. Install the service by typing the command: service.bat install

4. The above step will register a service by the name of Celoxis

5. Go to Control Panel -> Administrative Tools -> Services -> Celoxis and right click on Properties to verify the
settings are correct

To remove Celoxis as a Service : 

1. Go to Control Panel -> Administrative Tools -> Services -> Celoxis and stop the service. (if you are using Vista
or Windows Server 2008 server, you will need to run the Services application using "run as administrator")

2. Open a command prompt (if you are using Vista or Windows 2008 server, you will need to run the command
prompt using "run as administrator")

3. cd to <CELOXIS-INSTALL-DIR>/psa_x.y.z/bin directory

4. Remove the service by typing the command: service.bat remove
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4.1. Starting the application

1. Go to the bin sub directory of psa_x.y.z

2. If on Microsoft Windows, double click startup.bat. This will open a terminal window. Do not close this
window.

If on Linux, run startup.sh from the command shell.

3. Celoxis is now running

4.2. Stopping the application

1. Go to the bin sub directory of psa_x.y.z

2. If on Microsoft Windows, double click shutdown.bat.

If on Linux, run shutdown.sh from the command shell.

3. Celoxis is now stopped

4.3. Restarting the application

1. Go to the bin sub directory of psa_x.y.z

2. If on Microsoft Windows, double click shutdown.bat.

If on Linux, run shutdown.sh from the command shell.

3. Celoxis is now stopped

4. If on Microsoft Windows, double click startup.bat. This will open a terminal window. Do not close this
window.

If on Linux, run startup.sh from the command shell.

5. Celoxis is now running
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5.1. Celoxis Email Account

Celoxis application requires a dedicated email account to work with so ask your system administrator to create one
on your email server. If you use an ISP and don't have your own email server, you can create an account with your
ISP. We recommend the user name celoxis. Celoxis will read and send emails using this email account just like
you do from your email client. Once you create the email account, configure Celoxis to use it on the Edit Settings

page via Toolbar→Setup→Site

Tip

Celoxis works with the free GMail service from Google. Read Q: 4 [10] for more information.

5.2. How Email Filing Works

Celoxis provides a unique way for users to reply via email and have their replies filed in the appropriate place; be
it task communication, task updates or forum topic replies.

When user A sends an email from task to user B, the application stores the email in it's database, changes the Re-
ply-To email header to something like: celoxis+<control-information>@company.com and sends it
to user B. When user B replies to that email, the email lands up for the celoxis's email inbox (not user A's inbox
because the Reply-To header was changed). Celoxis periodically polls its inbox and when it finds the reply emails
there, processes it by first looking at the control-information. The control information has the task ID and
other related information. After the replied email is filed for that task, celoxis sends the email to user A (again with
the Reply-To header changed with new control information).

In case you have chosen not to use the plussed style addressing, the control information is added to the subject of
the email.

5.3. Improving Performance While Sending Emails

If the result of any action causes emails to be delivered, then the email delivery takes place before the action is
completed and control returned to the user. The rationale is that in case of any errors the user is notified right then and
there. If however, your mail server is slow in delivering emails, you can turn on Threaded Delivery option on the Edit

Settings page via Toolbar→Setup→Site. When this option is turned on, emails will be delivered in the background,
thus improving performance for the end users. However the drawback is that the user does not get instant feedback
about the status of the email.

5.4. Frequently Asked Questions

1. How do I disable all email notifications?
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From the main menu, go to Setup→Site and then click on Edit Settings. Un-check the Email Notifications
option and submit. Then restart the application.

2. How does a user customize the emails that he/she receives

Any user can customize their email notifications. From the main menu, go to Setup→Personal and then click
on Configure Email Notifications

3. Sending email fails for email addresses external to the organization. Why?

When the application tries to send an email to an external address, it contacts your SMTP server and asks it to
relay the email. Your SMTP server is responsible for relaying, not the application. The configuration of this
server determines whether such relaying is allowed, and which addresses are considered internal vs. external.

Check the following:

1. Whether your email client is configured with the same server as that configured for Celoxis. It should in
most cases be the same.

2. Check whether you have SMTP authentication enabled in Celoxis and whether the authentication type,
the username and password are correct.

3. Contact your system administrator and ask him/her to check one of the bounced email and/or mail server
log files. It will most likely have a reason on why the email is being rejected.

If you still don't understand, forward one of the bounced email (as attachment, not inline) to our support team
and we will assist you.

4. Can I use a GMail account for Celoxis?

Yes. GMail is a free, secure and reliable alternative to creating accounts for Celoxis on your email server.
Instead of creating an email account with your ISP, you can create an email account for Celoxis (say user-
name like celoxis.abc@gmail.com) in Gmail. Sample settings are shown below. Replace celoxis.abc
and celoxis123 with your gmail user name and password.
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Figure 5.1. Gmail Settings
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Chapter 6. Setting up Gantt Web Service
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6.1. Improved Gantt Chart

Since version 4.5, Celoxis provides an enhanced gantt chart. The new Gantt displays connector lines between tasks,
shows summary tasks as displayed as in Microsoft Project™ and last but not the least - it can be saved as an image
which means it can be included in reports or even emailed to clients and others.

6.2. How Gantt Charts are drawn

Celoxis is written in Java but the Gantt chart is drawn using software written in PHP (another language). So that
you don't have to install this software separately, your application will be configured to use the web service running
on Celoxis servers to generate the Gantt chart. For this to work, the computer on which you run the Celoxis
application must have an internet connection. When you click on the Gantt chart link in the application, the
application makes a secure connection (using SSL) to our server and supplies the task and project details to draw the
Gantt. Our server draws the Gantt and returns the image. Although your data is sent to our servers, we DO NOT
store the data or the Gantt images on our servers, not even temporary files. The entire operation is performed
in memory.

Our servers are highly secure and highly available and is the recommended and most convenient option. If however,
your organization's policy disallows transmitting such data over the internet then you can either disable the enhanced
Gantt chart which will draw Gantt charts in the old style (without the connector lines between tasks) or you can run
the web service on your network as described in Setting up your own Gantt Web Service (Section 6.3) [ ]

6.3. Setting up your own Gantt Web Service

Table of Contents

6.3.1. Prerequistes .......................................................................................................................................  12
6.3.2. Installing the software ........................................................................................................................  13

We recommend that you use the web service running on our servers to draw your Gantt charts as it is the most
convenient option. However, you can run the web service on your network as well.

6.3.1. Prerequistes

• A web server that can run PHP 5.2 like Apache.

• PHP 5.2 with:

• JSON and GD modules (these modules may be part of PHP 5.2 that you install)
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• In your PHP configuration file,

• Set magic_quotes_gpc to Off

• Set memory_limit to 64M (at least)

6.3.2. Installing the software

The software required to generate the Gantt is already bundled in Celoxis and is located in the directory psa_x.y.z/
webapps/psa/WEB-INF/gantt.

• Make a web alias /gantt/ that points to the web directory inside the above directory. The src and resources
directories should not be accessible via the web for security reasons.

If you are using Apache, you will have to add something like the following to Apache's configuration file
(httpd.conf) file and then restart the web server:

Alias /gantt/ "C:/usr/celoxis/psa_x.y.z/webapps/psa/WEB-INF/gantt/web/"

Linux users will need to use linux style path names.

• The software uses Arial font for the text in the Gantt chart. It looks for the font files in specific locations depending
on your operating system.

On Windows: This will be the system's font directory. Is almost all cases nothing will need to be done as the font
is part of the standard installation and will already be present in the font directory.

On Linux: The directory is /usr/share/fonts/truetype/. Copy the font files (arial.ttf,
arialbd.ttf, arialbi.ttf, ariali.ttf) to this directory. Create the directory (if it does not already
exist) and ensure that the files are readable by everyone. If you have installed the true type fonts on your system,
the directory and the font files may already exist and nothing may need to be done.

To use a different font, copy the necessary fonts in the directories mentioned above and edit the src/gantt.ini
file to include those fonts.

• To confirm that your installation is correct, point your browser to: http://your-web-server/gantt/gantt.php?
cmd=test. If you see a success message all is well else you will see an error message describing the problem.

• Once the installation is successful, you will have to configure Celoxis to contact your web service instead of the
one provided by us.

To modify the web service setting,

• From the main menu, go to Setup→Site.

• Click on Edit Settings.

• Under the Gantt section, choose Use Enhanced Gantt and type http://your-web-server/gantt/
gantt.php as the web service URL.

• Restart Celoxis.
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Chapter 7. Allocating Memory to Tomcat
By default Tomcat (the bundled web server) is configured to use a maximum of 768 MB of memory which is quite
sufficient in majority of cases. In case this proves insufficient for you, you can increase it as follows:

1. First determine the amount of memory you want to allocate. Typically, it should not exceed half of your installed
RAM. For example, if you have 4 GB of RAM, then you can safely allocate 2 GB to Tomcat. Let's assume you
want to set it to 2 GB i.e. 2048 MB.

2. Stop Celoxis

3. Set the system environment variable CATALINA_OPTS to -Xmx2048M (Note the dash in front of the X)

On Microsoft Windows

a. Right click on My Computer

b. Click Properties

c. Click on the Advanced tab (or click on Advanced system settings in Windows Vista)

d. Click the Environment Variables... button

e. Under System variables, click New...

f. Set variable name to CATALINA_OPTS and variable value to -Xmx2048M

g. Click OK

h. Click OK on the Advanced tab to close the window

On Linux

a. Open a terminal and login as the user that starts Celoxis

b. In the appropriate profile file (e.g. .bash_profile or .profile), type: export CATALINA_OPTS=-Xmx2048M

c. Save the file

d. Logout and Login again

4. Start Celoxis
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Chapter 8. Accessing Celoxis using SSL
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When web applications are being accessed across the internet, there is always the possibility of usernames and pass-
words being intercepted by intermediaries (eg. between your computer and the server). It is often a good idea to enable
access via HTTPS (HTTP over SSL), and require its use for pages where passwords are sent. Celoxis is bundled with
a self-signed certificate and is accessible with SSL using: https://<server-name>:8843/psa/user.do

8.1. Using your own SSL Certficate

In case you do not want to use the default self-signed certificate, and want to use your own certificate (e.g. provided
by companies like Verisign, Thawte, etc.) you will need to follow their instructions on how to obtain and install their
certificate into tomcat. The certificate should be installed into the file .keystore in psa_x.y.z directory with
pass phrase celoxis. Since the file is already present you will first have to delete the file. In case you want to change
the passphrase, you will have to update the psa_x.y.z/conf/server.xml and enter the new passphrase so
that the server can correctly read the key store. Restart the application after you are done.

Note

Any changes you make to the keystore or server.xml must be manually copied over after every upgrade

8.2. Changing the default SSL port

In case you need to change the SSL port which is 8843, you will need to edit psa_x.y.z/conf/server.xml
file and replace 8843 with the desired value. Restart the application.

Note

Any changes you make to the server.xml must be manually copied over after every upgrade

8.3. Disabling non SSL access

If you want to exclusively use SSL (HTTPS) and disable HTTP, do the following:

1. Delete the line <Connector port="8888"/> in the psa_x.y.z/conf/server.xml file

2. From the main menu, click Setup→Site

3. Click Edit Settings

4. Change the http to https in the URL prefix

5. Click Save

6. Restart the application



Accessing Celoxis using SSL

16

Note

Any changes you make to the server.xml must be manually copied over after every upgrade
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Chapter 9. Creating Subsidiaries
You can create subsidiaries/additional companies. Each subsidiary will have its own administrator, managers, users,
clients. Data cannot be shared between the subsidiaries.

To create a subsidiary point your browser to: http://<server>:8888/psa/sa.InputAddCompany.do
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Chapter 10. Regular Maintenance
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It is recommended that you regularly backup the database and data directory (that stores uploaded documents and
other information).

To find the location of your data directory :

1. From main menu, click Setup→Site

2. Click Edit Settings

3. Under Data Directory Path, the Path setting is the location of your data directory

10.1. Maintenance for PostgreSQL Database

To backup the database (on Linux) :

1. Open a command prompt

2. Type:

pg_dump -U [database-user] -Ft [database-name] > [filename]

This will create a dump file which can be restored using the pg_restore command. Please read the Postgresql
administration guide for more options and details.

To backup the database (on Microsoft Windows) :

1. Open pgAdmin tool

2. Open the server node and navigate to your database

3. Right click on your database and choose Backup...

4. Enter a file name. Leave the other defaults as is.

5. Click OK

Tip

It is recommended that you set the autovacuum parameter in postgresql.conf to on. This will
automatically optimize your database.

10.2. Maintenance for Microsoft SQL Server Database

To create a database user and database, open SQL Server Management Studio and login as sa (the database admin-
istrator user).
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To backup the database :

1. Open the Databases node

2. Right click on the Celoxis database node and click Tasks→Backup...

3. Select the approrpiate options

4. Click OK

Tip

To keep your database optimized, we suggest that you rebuild your database indexes regularly. Contact
your database administrator for more information.
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Chapter 11. Miscellaneous Topics
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11.1. How to set an environment variable

On Microsoft Windows

1. Right click on My Computer

2. Click Properties

3. Click on the Advanced tab (or click on Advanced system settings in Windows Vista)

4. Click the Environment Variables... button

5. Under System variables, click New...

6. Set variable name and variable value as indicated

7. Click OK

8. Click OK on the Advanced tab to close the window

On Linux

1. Open a terminal and login as the user that will start Celoxis

2. In the appropriate profile file (e.g. .bash_profile or .profile), type: export vari-
able-name=variable-value

3. Save the file

4. Logout and Login again

After you set the environment variable, you will need to restart the application.

11.2. How to send us the celoxis.log file

The log file contains various debugging messages that will help us resolved your problems. The file is named
celoxis.log and is located in the folder : <CELOXIS-INSTALL-DIR>/psa_4.x.y/webapps/psa/
WEB-INF/logs. Please send a zipped version of this file to support@celoxis.com.

11.3. How to apply a new license file

You will receive a license.properties file from us. To apply the new license file :

1. Stop Celoxis
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2. Save the license.properties file sent by us via email on to your computer

3. Copy the file to <CELOXIS-INSTALL-DIR>/psa_4.x.y/webapps/psa/WEB-INF/conf

4. Start Celoxis

11.4. How to move the application to another machine

Assume that M1 is the old server and M2 is the new server. Further assume that the application is installed at C:
\celoxis on M1 and we want to move it to the same location on M2.

Before you begin

Know your data directory location. Data directory is where the application keeps all uploaded files. To know your
data directory :

1. Login to the application on M1

2. From the main menu, click Setup→Site

3. Click Edit Settings

4. Check under the Data Directory section

Create new database and copy data from old database (if required)

1. If you are changing your database server, you will need to create and configure a new database for the application.
Note down the new database's host name, database name, user name and password. This will be required later.
For instructions on how to create a new database, please read : Database Setup (Chapter 2) [2].

2. Once you create this new database, copy over the database from the old server to the new server.

Apply for a license

• You will require a license from us to install the software on your new server. Use the same information used to
create the new database to apply for a license else the license file will be invalid. To apply for a license, please
visit : http://www.celoxis.com/license.php. You will receive the license file from us in one business day.

Install and configure Java on M2

• You will need to install and configure Java on the new machine. For instructions please read : Before You Begin
(Section 3.1) [5]

Copy application binaries to M2

1. Copy the entire C:\celoxis directory from M1 to M2. Now you will have C:\celoxis on M2.

2. Save the license.properties file that you have received in email from us for M2 on your computer

3. Copy the license.properties file to C:\celoxis\psa_x.y.z\webapps\psa\WEB-INF\conf
on M2

Copy data directory to M2

1. Assuming data directory is C:\celoxis\data on M1. Copy it to C:\celoxis\data on M2.

http://www.celoxis.com/license.php
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2. Ensure that C:\celoxis\data has requisite permissions

Update new database settings on M2

1. Open the file C:\celoxis\psa_x.y.z\webapps\psa\WEB-INF\conf\db.properties on M2

2. Change the user name and password properties in the file to their new values. If you are using the same database
login and password, you will not need to change anything.

3. Save the file

Stop application on M1

• Stop the application on the old server. Read Stopping the application (Section 4.2) [8] on how to stop the ap-
plication.

Start application on M2

• Start the application on the new server. Read Starting the application (Section 4.1) [8] on how to start the
application.

Edit settings on M2

1. Logon to the application on M2

2. From the main menu, click Setup→Site

3. Click Edit Settings

4. Change the URL prefix to use M2 instead of M1. E.g. then you will have to enter something like http://
M2.mycompany.com:8888/

5. Click on Save

6. Restart the application
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Chapter 12. What if I get errors?
If you get any errors, check if you can fix them. If not, send an email to support@celoxis.com and include the exact
error message. Copy and paste all the text from the window. This will help us understand the problem.

Important

The database might be left in an inconsistent state. Drop and recreate the database.
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